Verification is currently underway for the maintenance items.
Posted Jun 24, 2026 - 01:22 BST
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jun 23, 2026 - 19:30 BST
Update
We will be undergoing scheduled maintenance during this time.
Posted Jun 23, 2026 - 11:04 BST
Scheduled
We’ve got maintenance planned for your smart meter on Tuesday 23 June, which is scheduled from 7:30pm to 4am. Don’t worry – this won’t affect your energy supply because you'll be in Friendly Credit Hours until 10am on Wednesday 24 June.
During the maintenance window, Top-ups, the Top-up Phone Line, In Store Payments, Guest Payments, POWER UPs and Credit Transfers will be unavailable for all customers.
Posted Jun 23, 2026 - 08:53 BST
This scheduled maintenance affected: Payments (SMETS1 Smart Meters, SMETS1 (DCC Enrolled) Smart Meters, SMETS2 Smart Meters, Guest Payments, PayPoint - In Store Payments, PayPoint - IVR Top-up Phone Line, PayZone - In Store Payments, Open Banking), My Utilita (Power-up Functionality), Websites (join.utilita.co.uk), and Smart Meter Installations, Smart Metering Network.