We’re sorry - there’s a problem with My Utilita payments

Incident Report for Utilita Status Page

Resolved

This incident has been resolved.
Posted Jan 29, 2026 - 17:34 GMT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jan 29, 2026 - 16:57 GMT

Investigating

We're sorry, Open Banking in the My Utilita app currently isn't working due to an issue from our supplier. We're hoping this will be fixed soon - but in the meantime, all other payment methods are working as normal.

Don't worry about losing supply, you'll be in Friendly Credit Hours until tomorrow morning at 10am. Please keep an eye on our service page for the latest info!
Posted Jan 29, 2026 - 14:29 GMT