Oops! There’s a problem with some Smart Meters

Incident Report for Utilita Status Page

Resolved

This incident has been resolved.
Posted Aug 03, 2026 - 16:25 BST

Investigating

We’re sorry, there's currently a problem with a number of our smart meters, which means some of our customers aren't receiving updates to their smart meters.

If you've topped up and the payment isn't showing, you just need to manually enter your 20-digit Top-Up Code into your meter.

We’re working hard to fix the issue and we're sorry for any inconvenience this may cause.
Posted Aug 03, 2026 - 12:07 BST
This incident affected: Payments (SMETS1 (DCC Enrolled) Smart Meters, SMETS2 Smart Meters) and Smart Metering Network.