We’re sorry - there’s a problem with My Utilita payments

Incident Report for Utilita Status Page

Resolved

This incident has been resolved.
Posted Jul 16, 2025 - 12:31 BST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 16, 2025 - 11:59 BST

Identified

The issue has been identified and a fix is being implemented.
Posted Jul 16, 2025 - 10:49 BST

Investigating

We’re sorry, there’s currently a problem with My Utilita payments – we’re working hard to sort it and in the meantime, you can top-up via https://utilitapayments.paypoint.com/GuestPayment.

Keep an eye on our service page for the latest info – we’ll be back to normal soon.
Posted Jul 16, 2025 - 10:05 BST
This incident affected: Payments (SMETS1 Smart Meters, SMETS1 (DCC Enrolled) Smart Meters, SMETS2 Smart Meters, Guest Payments).