Verification is currently underway for the maintenance items.
Posted Dec 10, 2025 - 02:05 GMT
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Dec 09, 2025 - 19:30 GMT
Scheduled
We’ve got maintenance planned for your smart meter on 9 December 2025 scheduled from 7.30pm to 4am. Don’t worry – this won’t affect your energy supply because you'll be in Friendly Credit Hours until 10am on 10 December 2025.
During the maintenance window top-ups, POWER-UPs and credit transfers will be unavailable for all customers.
Posted Dec 08, 2025 - 08:51 GMT
This scheduled maintenance affected: Payments (SMETS1 Smart Meters, SMETS1 (DCC Enrolled) Smart Meters, SMETS2 Smart Meters, Guest Payments, PayPoint - In Store Payments, PayPoint - IVR Top-up Phone Line, PayZone - In Store Payments), My Utilita (App, Power-up Functionality, Web Portal), and Smart Meter Installations, Smart Metering Network.