We’re sorry - there’s a problem with My Utilita payments

Incident Report for Utilita Status Page

Resolved

This incident has been resolved.
Posted Jul 29, 2026 - 05:19 BST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 29, 2026 - 05:11 BST

Update

We are continuing to investigate this issue.
Posted Jul 29, 2026 - 04:42 BST

Investigating

We’re sorry, there is currently a problem with a small number of our second-generation smart meters.

Some of our customers are not receiving updates to their smart meters. If you have topped up and the payment is not showing you can manually enter your 20 digit top up code into your meter.

We’re working hard to fix the issue and we apologise for any inconvenience this may cause.
Posted Jul 29, 2026 - 03:06 BST
This incident affected: Payments (SMETS2 Smart Meters) and Smart Meter Installations, Smart Metering Network.