Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 10, 2026 - 21:30 GMT
Update
We will be undergoing scheduled maintenance during this time.
Posted Mar 09, 2026 - 13:46 GMT
Update
We will be undergoing scheduled maintenance during this time.
Posted Mar 09, 2026 - 11:54 GMT
Scheduled
We’ve got maintenance planned for your smart meter on Tuesday 10 March scheduled from 9:30pm to 5am. Don’t worry – this won’t affect your energy supply because you'll be in friendly credit hours until 10am on Wednesday 11 March.
During the maintenance window, top-ups, power-ups and credit transfers will be unavailable for a small subset of customers.
Posted Mar 09, 2026 - 11:35 GMT
This scheduled maintenance affected: My Utilita (Power-up Functionality), Payments (SMETS2 Smart Meters, Guest Payments, PayPoint - In Store Payments, PayPoint - IVR Top-up Phone Line, PayZone - In Store Payments, Open Banking), and Smart Meter Installations, Smart Metering Network.